[jira] [Commented] (DISPATCH-753) Neither version of console is usable on Internet Explorer 10 or 11

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

[jira] [Commented] (DISPATCH-753) Neither version of console is usable on Internet Explorer 10 or 11

JIRA jira@apache.org

    [ https://issues.apache.org/jira/browse/DISPATCH-753?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16053794#comment-16053794 ]

Jiri Danek commented on DISPATCH-753:
-------------------------------------

For the hawtio version yes, that works fine on Windows 7/IE11.

The stand-alone version does not, essentially all previously observed issues are still present: the Overview tab does not display, the Topology tab does not display, tables for entities on the Entities tab are empty.

Having the hawtio version fixed is good enough for me. I would not object if stand-alone version was decided to be supporting Microsoft Edge 14 or newer.

I am testing with a build of

{noformat}
commit 47724c7c42ee9fca15a06baeab5af40abf9aed2b
Author: Ernest Allen <[hidden email]>
Date:   Sat Jun 17 20:23:31 2017 -0400

    DISPATCH-750 Force font-family for FontAwesome fonts for Windows support
{noformat}

> Neither version of console is usable on Internet Explorer 10 or 11
> ------------------------------------------------------------------
>
>                 Key: DISPATCH-753
>                 URL: https://issues.apache.org/jira/browse/DISPATCH-753
>             Project: Qpid Dispatch
>          Issue Type: Bug
>          Components: Console
>    Affects Versions: 0.8.0
>         Environment: Windows 7, Internet Explorer 10 and 11 (running in a virtual machine provided at https://developer.microsoft.com/en-us/microsoft-edge/tools/vms/)
>            Reporter: Jiri Danek
>            Assignee: Ernest Allen
>             Fix For: 0.8.1, 1.0.0
>
>
> This is a complete console output from Hawtio version on WIndows 7 and Internet Explorer 10
> {noformat}
> SCRIPT1002: Syntax error
> hawtio, line 955 character 19
> [Window] Syntax error (<a href=":955">:955:19</a>)
> [PluginLoader] Failed loading script: "Could not complete the operation due to error 80020101." (<a href="/dispatch-hawtio-console/plugin/js/qdrOverview.js:undefined">/dispatch-hawtio-console/plugin/js/qdrOverview.js:undefined</a>)
> SCRIPT1006: Expected ')'
> hawtio, line 492 character 45
> [Window] Expected ')' (<a href=":492">:492:45</a>)
> [PluginLoader] Failed loading script: "Could not complete the operation due to error 80020101." (<a href="/dispatch-hawtio-console/plugin/js/qdrTopology.js:undefined">/dispatch-hawtio-console/plugin/js/qdrTopology.js:undefined</a>)
> [Themes] unknown theme name, using default theme
> [QDR] *************creating Dispatch Console************
> [QDR] curPath is /
> [Core] hawtio started
> [RBAC] Using mbean hawtio:type=security,area=jmx,rank=0,name=HawtioDummyJMXSecurity for client-side role based access control
> XML5632: Only one root element is allowed.
> , line 3 character 2
> [QDR] okay to start
> [QDR] [
>   "amqp:/_topo/0/Router.A/$management"
> ]
> [QDR] {
>   "amqp:/_topo/0/Router.A/$management": {}
> }
> [QDR] saving page changed to /dispatch_hawtio_console/overview
> Error: Error: Argument 'QDR.OverviewController' is not a function, got undefined
> Stack trace: <div class="log-stack-trace">
> <p>Error: Argument 'QDR.OverviewController' is not a function, got undefined</p>
> <p>   at _ (http://10.0.2.2:8080/hawtio/app/app.js?c8641b2e13788127:13:8946)</p>
> <p>   at aa (http://10.0.2.2:8080/hawtio/app/app.js?c8641b2e13788127:13:9037)</p>
> <p>   at Anonymous function (http://10.0.2.2:8080/hawtio/app/app.js?c8641b2e13788127:13:28890)</p>
> <p>   at Anonymous function (http://10.0.2.2:8080/hawtio/app/app.js?c8641b2e13788127:13:24327)</p>
> <p>   at f (http://10.0.2.2:8080/hawtio/app/app.js?c8641b2e13788127:13:3544)</p>
> <p>   at n (http://10.0.2.2:8080/hawtio/app/app.js?c8641b2e13788127:13:24131)</p>
> <p>   at f (http://10.0.2.2:8080/hawtio/app/app.js?c8641b2e13788127:13:22086)</p>
> <p>   at Anonymous function (http://10.0.2.2:8080/hawtio/app/app.js?c8641b2e13788127:13:21616)</p>
> <p>   at k (http://10.0.2.2:8080/hawtio/app/app.js?c8641b2e13788127:15:22785)</p>
> <p>   at $broadcast (http://10.0.2.2:8080/hawtio/app/app.js?c8641b2e13788127:14:17750)</p>
> </div>
> {noformat}
> This is complete output from stand-alone version on the same system Windows 7 and Internet Explorer 10
> {noformat}
> SCRIPT12008: WebSocket Error: Incorrect HTTP response. Status code 200,  
> [connection-1] error: [object Event]
> [connection-1] disconnected  
> [connection-1] disconnected  
> QDR: routeChangeSuccess: path is now /
> Error: [$controller:ctrlreg] The controller with the name 'QDR.OverviewController' is not registered.
> http://errors.angularjs.org/1.6.2/$controller/ctrlreg?p0=QDR.OverviewController
>    at $controller (https://ajax.googleapis.com/ajax/libs/angularjs/1.6.2/angular.js:10690:11)
>    at setupControllers (https://ajax.googleapis.com/ajax/libs/angularjs/1.6.2/angular.js:9779:9)
>    at nodeLinkFn (https://ajax.googleapis.com/ajax/libs/angularjs/1.6.2/angular.js:9549:11)
>    at compositeLinkFn (https://ajax.googleapis.com/ajax/libs/angularjs/1.6.2/angular.js:8903:13)
>    at publicLinkFn (https://ajax.googleapis.com/ajax/libs/angularjs/1.6.2/angular.js:8768:30)
>    at link (https://ajax.googleapis.com/ajax/libs/angularjs/1.6.2/angular-route.min.js:7:490)
>    at Anonymous function (https://ajax.googleapis.com/ajax/libs/angularjs/1.6.2/angular.js:1290:11)
>    at invokeLinkFn (https://ajax.googleapis.com/ajax/libs/angularjs/1.6.2/angular.js:10274:9)
>    at nodeLinkFn (https://ajax.googleapis.com/ajax/libs/angularjs/1.6.2/angular.js:9663:11)
>    at compositeLinkFn (https://ajax.googleapis.com/ajax/libs/angularjs/1.6.2/angular.js:8903:13)<div class="ng-scope" ng-view="">
>  QDR: failed to auto-connect to 10.0.2.2:8080
> QDR: routeChangeSuccess: path is now /connect
> $tooltip is now deprecated. Use $uibTooltip instead.
>  QDR: ****** calling rhea.connect ********
>  QDR: rhea.connect was not passed an existing connection
>  QDR: testConnect called with reconnect true using ws protocol
>  QDR: exception caught on test connect SyntaxError
> {noformat}
> Personally, I do not care much about Internet Explorer 10. It should be investigated if anyone using Dispatch (or productizing Dispatch) cares.



--
This message was sent by Atlassian JIRA
(v6.4.14#64029)

---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]